https://www.acmicpc.net/problem/23627
문제
드립이는 "driip"으로 끝나는 문자열은 모두 귀엽다고 생각한다.
다음 문자열들은 드립이가 귀엽다고 생각하는 문자열들의 예시이다. "dogdriip", "catdriip", "driip"
다음 문자열들은 드립이가 귀엽다고 생각하지 않는 문자열들의 예시이다. "dogdrip", "driipcat", "driiiiip"
문자열이 주어지면, 드립이가 주어진 문자열을 귀엽다고 생각하는지 판단하는 프로그램을 작성하자.
입력
첫째 줄에 문자열 S(1 ≤ |S| ≤ 1,000)가 주어진다. 주어지는 문자열은 영문 소문자로만 이루어져 있다.
출력
드립이가 생각하기에 주어진 문자열이 귀여우면 "cute", 그렇지 않으면 "not cute"를 출력한다. (따옴표 제외)
예제 입력 1
dogdriip
예제 출력 1
cute
예제 입력 2
goricon
예제 출력 2
not cute
예제 입력 3
h
예제 출력 3
not cute
코드
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
|
using namespace std;
#include <iostream>
#include <iomanip>
#include <string>
#include <cstring>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <deque>
#include <functional>
#include <cmath>
#include <map>
#include <set>
#define _CRT_SECURE_NO_WARNINGS
#define INF 987654321
#define ll long long
typedef pair<int, int> PII;
int main() {
string s, temp = "";
cin >> s;
for (int i = s.size() - 5; i <= s.size() - 1; i++) {
temp += s[i];
}
if (temp == "driip") cout << "cute" << "\n";
else cout << "not cute" << "\n";
return 0;
}
|
cs |
728x90
반응형
'🔻PS > Baekjoon' 카테고리의 다른 글
[Baekjoon] 백준 26082 WARBOY C++ (0) | 2022.12.19 |
---|---|
[Baekjoon] 백준 26265 멘토와 멘티 C++ (0) | 2022.12.18 |
[Baekjoon] 백준 25192 인사성 밝은 곰곰이 C++ (0) | 2022.12.15 |
[Baekjoon] 백준 26069 붙임성 좋은 총총이 C++ (0) | 2022.12.13 |
[Baekjoon] 백준 26068 치킨댄스를 추는 곰곰이를 본 임스 2 C++ (0) | 2022.12.12 |